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[!DNL Elasticsearch] is shown as the search engine despite [!DNL OpenSearch] installation
[!DNL Elasticsearch] is shown as the search engine despite [!DNL OpenSearch] installation
This article provides a solution for the issue where [!DNL Elasticsearch] is still shown as the search engine for Adobe Commerce on cloud even after installing or upgrading to [!DNL OpenSearch].
Affected versions
Adobe Commerce on cloud (all versions)
Issue
[!DNL Elasticsearch] is still shown as the search engine for Adobe Commerce on cloud even after installing or upgrading to [!DNL OpenSearch].
Steps to reproduce :
Go to [!UICONTROL Stores] > [!UICONTROL Configuration] > [!UICONTROL Catalog] > [!UICONTROL Catalog Search] .
Check the search engine. It will show [!DNL Elasticsearch7].
Cause
Adobe Commerce is hard-coded to specify [!DNL Elasticsearch7] as the search engine.
Solution
To verify if [!DNL OpenSearch] has been installed, run the following command:
Method 1 :
Run the following command on server: curl 127.0.0.1:9200
. It should return [!DNL OpenSearch] with its version.
Method 2 :
Use the following command on the Magento-cloud CLI: magento-cloud relationships -p <project_id>
. After using the command, locate [!DNL OpenSearch].
Set up OpenSearch service in the Commerce on Cloud Infrastructure guide.
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