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Troubleshooting New Relic on Adobe Commerce on cloud infrastructure
Troubleshooting New Relic on Adobe Commerce on cloud infrastructure
This article provides resources for troubleshooting New Relic on Adobe Commerce on cloud infrastructure.
Issue |
Cause |
Resources |
Access Issues |
Can't see projects in New Relic.
You log in to New Relic but can't see projects you should be entitled to view/access.
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In those cases, an admin user needs to add you to the project.
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Accessing New Relic services in our support knowledge base.
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Data Issues |
Missing data after installation.
Use the New Relic Diagnostics utility to try to identify the cause. If this does not help, look at agent specific solutions. Links to articles containing these solutions are in the right-hand column.
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Missing data can have different causes. You may need to:
- Verify the agent is installed.
- Verify your app name and license key.
- Restart your web server.
- Make sure your system meets compatibility requirements.
- INI settings.
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Transactions timestamp discrepancy. You may struggle to find long transactions (more than 5 mins) using the New Relic UI. You may also find transactions displayed outside of the expected time frame.
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The New Relic UI displays the time of the transaction's end, not the time when the transaction began.
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To calculate the beginning of the transaction using the New Relic UI, check the duration of the transaction. Subtract the duration amount from the timestamp (end of transaction) provided by the New Relic UI.
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NerdGraph GraphQL curl queries using special characters such as | and % do not work.
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New Relic "copy to curl" feature within NerdGraph does not currently provide a way to handle special characters such as | and % .
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Use a different API library to solve the issue with special characters. For example, GraphQLClient Library for Graphql API on Python, or Apache.commons by Java Language calls. Review client libraries on GraphQL.
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Chart and dashboard display issues.
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Resolve missing charts by adding New Relic domains to the allow list or uninstall the browser extension causing the issues.
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New Relic Documentation > Charts missing or do not render
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PHP Agent Issues |
PHP agent does not show the correct instance count.
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The number of instances can increase depending on back end processes and throughput. Differences between server values can be due to processes running on one server, but not the other server.
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New Relic Documentation > Troubleshoot the PHP agent instance count
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