This page has moved to Adobe Experience League and will be redirected soon.
Vertex Address Cleansing: different addresses not allowed
Vertex Address Cleansing: different addresses not allowed
This article talks about the solution for the issue where when the user tries to enter a different billing and shipping address, with Vertex address validation enabled, the storefront will not let the user enter it.
Affected products and versions
- Adobe Commerce on-premises and Adobe Commerce on cloud infrastructure 2.3.5-p1
Issue
Steps to reproduce:
- Go to Admin > Stores > Configuration > Sales > Address Cleansing.
- Select Enabled from the Use Vertex Address Cleansing drop-down and Save Config.
- Go to the frontend as a guest and add a product to the cart.
- Click on the Cart icon and Proceed to Checkout.
- Fill in the address fields.
- Select desired Shipping Method and click Next.
- Click on the Next button again.
- Uncheck My billing and shipping address are the same, and enter a new billing address (different to Address).
- Click the Update button, then click Update address.
Expected results:
The user sees different billing and shipping addresses.
Actual results:
When the user hits update, the billing and shipping addresses revert to being the same.
Cause
Vertex address verification has failed.
Solution
Disable Vertex Address verification or upgrade to 2.4.0.